Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Trigger Delay on CV16 Tracks
#1
I searched for this and can't find any posts about trigger delay on CV16 tracks.

Finally had some time to actually sit down and work on some music with my new dual CV16 setup. I'm having a problem with my BIAs getting the trigger too soon before the CV. I was using trigger delays before to counteract this (using T01 on CV/Gate tracks), but it seems like I can't do any kind of trigger delay on CV16 tracks. Would it be possible to add either trigger delay in the track setup, or, add an option to the trigger command (something like TT9 to TTF would be a 5ms trigger with a 5ms delay at TT9 to a 35ms delay at TTF)?

The workaround I have right now using my Ornament & Crime in quad envelope mode with a small delay to the envelopes to delay the triggers. So, this isn't like a "show-stopping problem" at the moment.

Preferably, I'd really just like the CV16 track setup to have autogate on/off, trigger length and trigger delay for any lane set to local CV (which the CV16 doesn't seem to be able to do, unless that's there and I just can't figure it out?!).

The other problem with needing to use a trigger command on a CV16 track is that it seems to mess up actually sending CV. If I put a local trigger event in a CV16 lane (set to a CV16 output), then put a voltage value, that value doesn't seem to get sent to the CV16's output. This might be a related issue? Maybe I should put this in bug reports so it doesn't get lost.
Reply
#2
(11-12-2020, 09:12 PM)the_cody Wrote: I searched for this and can't find any posts about trigger delay on CV16 tracks.

Finally had some time to actually sit down and work on some music with my new dual CV16 setup. I'm having a problem with my BIAs getting the trigger too soon before the CV. I was using trigger delays before to counteract this (using T01 on CV/Gate tracks), but it seems like I can't do any kind of trigger delay on CV16 tracks. Would it be possible to add either trigger delay in the track setup, or, add an option to the trigger command (something like TT9 to TTF would be a 5ms trigger with a 5ms delay at TT9 to a 35ms delay at TTF)?

The workaround I have right now using my Ornament & Crime in quad envelope mode with a small delay to the envelopes to delay the triggers. So, this isn't like a "show-stopping problem" at the moment.

Preferably, I'd really just like the CV16 track setup to have autogate on/off, trigger length and trigger delay for any lane set to local CV (which the CV16 doesn't seem to be able to do, unless that's there and I just can't figure it out?!).

The other problem with needing to use a trigger command on a CV16 track is that it seems to mess up actually sending CV. If I put a local trigger event in a CV16 lane (set to a CV16 output), then put a voltage value, that value doesn't seem to get sent to the CV16's output. This might be a related issue? Maybe I should put this in bug reports so it doesn't get lost.

Are you using a Trigger with value of 01 on a regular track to get the delay? This actually sets a delayed gate (5ms in that case).
This is also possible from the CV16 in a FX column. That doesn't have anything to do with the Trigger Delay setting for CV/Gate tracks.
I think basically it should be possible to add also a Trigger delay for the CV16 tracks for the local triggers like with the CV/Gate tracks.
Alternatively, did you try using an envelope as trigger on a CV16 output? You might be able to add some kind of delay with a somehow slower attack together with correct AMP settings.

The CV16 Lanes don't work with gates, so there is no autogate function and will not be (there is also no note off to reset the gate again) and it wouldn't make much sense with 6 possible lanes which set the gate.


I am actually not aware that a trigger command messes up the CV sending. Can you add some more details or add a project file so i can check it out?
PLEASE use the search function if something have been asked or discussed before.
Every (unnessesary) forum support means less time to develop! But of course, i am here to help!  Smile
Reply
#3
(11-12-2020, 10:04 PM)XORadmin Wrote: Are you using a Trigger with value of 01 on a regular track to get the delay? This actually sets a delayed gate (5ms in that case).

Yep, that's how I was delaying gates before. Never got a chance to try out the delay in the track setup from firmware 1.21 before I went to 1.22

(11-12-2020, 10:04 PM)XORadmin Wrote: This is also possible from the CV16 in a FX column. That doesn't have anything to do with the Trigger Delay setting for CV/Gate tracks.

I didn't even THINK about using an FX slot for the trigger! That'll be WAY better!

(11-12-2020, 10:04 PM)XORadmin Wrote: I think basically it should be possible to add also a Trigger delay for the CV16 tracks for the local triggers like with the CV/Gate tracks.

I think for my specific use case, this might be the best option. But, I don't know how many other people run in to this same issue? I'm sending a LOT of CV to two BIAs and a couple of the inputs need to receive the CV before trigger, otherwise its internal envelope does weird things. So, I end up delaying everything by 5ms to compensate for the delay I need for the BIAs (same for the Manis Iteritas as well, but I don't usually modulate the envelope so drastically on that). And, because I multitrack everything, I just shift the sample tracks by 5ms as well in Ableton.

(11-12-2020, 10:04 PM)XORadmin Wrote: Alternatively, did you try using an envelope as trigger on a CV16 output? You might be able to add some kind of delay with a somehow slower attack together with correct AMP settings.

I will also try this out. The only reason I hadn't is that I'm using all 6 lanes for CV already, so was trying to use the trigger out. But, with trigger from an FX lane will probably solve it for me.

(11-12-2020, 10:04 PM)XORadmin Wrote: The CV16 Lanes don't work with gates, so there is no autogate function and will not be (there is also no note off to reset the gate again) and it wouldn't make much sense with 6 possible lanes which set the gate.

That makes sense. I was thinking about asking for the ability to have a trigger as one of the lanes on the CV16 tracks, but it seemed kinda overkill. Using an envelope or an FX lane should be perfectly fine. Though, I'd totally still like trigger delay in the track setup so I can still use the local trigger event Wink (mostly so I can see it in the same page as everything else hahaha).

(11-12-2020, 10:04 PM)XORadmin Wrote: I am actually not aware that a trigger command messes up the CV sending. Can you add some more details or add a project file so i can check it out?

I had an envelope in attack->release mode going. Alternating TT2 and ^10 on the same external CV lane. I'll make a project file and upload it shortly.
Reply
#4
(11-13-2020, 01:01 AM)the_cody Wrote:
(11-12-2020, 10:04 PM)XORadmin Wrote: I am actually not aware that a trigger command messes up the CV sending. Can you add some more details or add a project file so i can check it out?
I had an envelope in attack->release mode going. Alternating TT2 and ^10 on the same external CV lane. I'll make a project file and upload it shortly.

Ok, I realized what I did wrong. I tried and couldn't reproduce it until I made the same mistake again. Seeing "TT1" and pressing shift+right only once and forgetting "TTT" is before "TT2" is what I must have done before. So, entirely my mistake on that. I'll get used to that soon enough. I think it just threw me because I haven't had a chance to really sit with the CV16 events long enough to feel completely comfortable with them (I probably have a cumulative like 45 minutes with them so far). Apologies for not recognizing that mistake sooner.
Reply
#5
https://www.instagram.com/p/CHhPhTBBBhk/...dcmricgdev

Ok, trigger in the FX lane feels totally fine. It’s a little slow to add new triggers, but it doesn’t feel unnatural or strange to do that. Also, I absolutely love that I can use “notes” for general CV values, as it’s WAAAAY easier to just see where values are at. And, as you can see from that link, I’m using all 6 lanes (plus two normal mods from FX lanes) to get an entire drum kit and a bass from one BIA. This is so so so much better than using the Voltage Block in “CV mode” (not as a sequencer) for this sorta “preset per step” sorta thing.
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)