XOR Userforum

Full Version: Chaining Tables strange behaviour
You're currently viewing a stripped down version of our content. View the full version with proper formatting.

Testing this with 1.24 RC11.

I have a table (00) that effectively plays a note sequence relative to the note the table is attached to (by means of values in the Transpose column and adding triggers where notes shall start). All fine. Now I want to extend the note sequence by the content of table 01 (another note sequence) and thus on step 0F of my table add FX TABLE 0000. So far all is fine.
I then move the cursor on the "0000" and press SHIFT+RIGHT and the value changes to "0001" as expected, though table 01 wasn't automatically chained or called.
Now starts the weirdness:
Pressing SHIFT+RIGHT again "moves" me into editing table 01 as if I had pressed TABLE+DOWN. There is no table 02 and I tried that to see how the parameter would change. Similar with SHIFT+UP and SHIFT+DOWN.
Pressing SHIFT+LEFT to change it back to 0000 doesn't work either.
Under some circumstances just pressing LEFT when on the value (0001 in that case) also moved me into editing 01.
The only way to get rid of the 0001 is moving onto TABLE and changing that into some other function. When I return to table it is TABLE 0000 again.

The pattern was playing while I did all of the above. Tables 00 and 01 are in >ONCE mode

Is this a bug or am I doing something silly?

Kind regards,
I got to check that. Might be that the current selected table is also changed when changing in the table FX.
Should be something small.
Yup, fixed it and goes into the release.
It changes the selected table when you navigate on the value or change it and then you are directly in the other table.

It has no impact to the sequence of the table, it's only a navigation thing.
Thank you Smile