XOR Userforum

Full Version: Chaining tables - how?
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Hi Forum!

I'm trying to chain two tables and can't get it to work. Here is what I do:
I have two tables 00 and 01. Both are set
Source: Int. Tick
Speed: 03
Type: >ONCE
no range, no quantization
Nothing in column HP, some values in TP and FX only TRIG except for table 00 which has TABL 0001 on step 0F

BPM is set to 60, otherwise it would be too fast.

The pattern looks like this:
00 C-6  ...  00 (in table column)
...
10 D-6  ...  00
...
20 E-6  ...  00
...
30 F-6  ...  00
...

However only table 00 is played, table 01 is never called.

I had expected this:
00 C-6  ...  00 (in table column)
...
08 C-6  ...  01
...
10 D-6  ...  00
...
18 D-6  ...  01
...
20 E-6  ...  00
...
28 E-6  ...  01
...
30 F-6  ...  00
...
38 F-6  ...  01
...

Am I doing something wrong?
How do I chain tables?

I'm on 1.24 RC11

Kind regards,
Michael
I think setting it to loop might help.

I don't have it in front of me right now, but it might be that the table stop is executed with the last step.

Guesswork right now for me. I got to try that, but I know I had proper table chaining of multiple tables.
(03-24-2021, 08:27 PM)XORadmin Wrote: [ -> ]I think setting it to loop might help.

I don't have it in front of me right now, but it might be that the table stop is executed with the last step.

Guesswork right now for me. I got to try that, but I know I had proper table chaining of multiple tables.

That got me on the right track.

It works, when I set table 01 to >LOOP. Table 00 can stay on >ONCE.

For me that is at least unexpected and I suggest it should be mentioned if not explained (i.e. the rationale behind it) in the manual.

Anyway, got it working now Smile

Thank you,
Michael