Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
MIDI step input without trigger value
#1
Question 
Hey everyone! I just got my Nerdseq, am having a lot of fun figuring it out. But there's this one thing that's annoying me: When entering notes via the MIDI Step Channel (using a Keystep), the trigger column always gets populated with 40, is there a way to disable that? / set the default duration? 

And since I am here asking dumb questions already: is there a way to enter Mod values via the step channel?

I did rtm but couldn't find anything  Confused
Reply
#2
(04-27-2021, 01:06 AM)headphonehead Wrote: Hey everyone! I just got my Nerdseq, am having a lot of fun figuring it out. But there's this one thing that's annoying me: When entering notes via the MIDI Step Channel (using a Keystep), the trigger column always gets populated with 40, is there a way to disable that? / set the default duration? 

I did rtm but couldn't find anything  Confused

This feature is called "Auto Fill-In Trigger". Described on page 75 in the manual V1.23 and page 80 in V1.24. Switch this off and no trigger are filled in.

HTH,
Michael
Reply
#3
(04-27-2021, 06:11 AM)mgd Wrote:
(04-27-2021, 01:06 AM)headphonehead Wrote: Hey everyone! I just got my Nerdseq, am having a lot of fun figuring it out. But there's this one thing that's annoying me: When entering notes via the MIDI Step Channel (using a Keystep), the trigger column always gets populated with 40, is there a way to disable that? / set the default duration? 

I did rtm but couldn't find anything  Confused

This feature is called "Auto Fill-In Trigger". Described on page 75 in the manual V1.23 and page 80 in V1.24. Switch this off and no trigger are filled in.

HTH,
Michael

Thanks for replying

It gets inserted regardless of whether auto fill in is on or off. Only difference is when it is off the trigger gets filled in when I release a key on the key step, while when it’s on it gets filled in immediately upon pressing a key.

Seems strange

Edit: after checking again, it looks like there’s no difference between the setting being on or off.
Here’s a video: https://share.icloud.com/photos/0yxuNFXP...DzvpoEDceg
Reply
#4
No, there is a difference.

If you release the key on the same step, then a trigger is filled in. This to still allow a note which is shorter than a step.
If you hold the key, and go with the cursor to another position and release the key, then a note off is filled in there instead of a value in the trigger column.
PLEASE use the search function if something have been asked or discussed before.
Every (unnessesary) forum support means less time to develop! But of course, i am here to help!  Smile
Reply
#5
(04-27-2021, 06:56 PM)XORadmin Wrote: No, there is a difference.

If you release the key on the same step, then a trigger is filled in. This to still allow a note which is shorter than a step.
If you hold the key, and go with the cursor to another position and release the key, then a note off is filled in there instead of a value in the trigger column.

Yes, that behavior is what I see. But what I was trying to say is that the "auto fill in trigger" setting has no effect when inputting steps via midi. I guess that's expected? It does affect note input via the nerdseq's buttons.

I didn't know about the "move cursor while sending midi note" input method. That basically resolves my problem (I was going back and erasing all the triggers after inputting notes one by one).

Thanks for the help!
Reply
#6
(04-28-2021, 01:41 AM)headphonehead Wrote: I was going back and erasing all the triggers after inputting notes one by one.

When you wish to erase any consecutive block of notes/triggers/... you can just mark and delete the whole block at once. No need to do it one by one.
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)