Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
External clocking timing error
#1
I have a project that I prepared at 88bpm with NerdSeq's internal master clock. It's a 4:30 minute continuous song and it includes modular tracks, a MIDI track, a Trigger 16 Expander and some sample tracks.
This evening, I tried to run it from my DAW (Reason), also at 88bpm, in two ways:
1) With NerdSeq set to "MIDI Slave" mode
2) With NerdSeq set to "Mod.Slave24" and receiving the 24ppqn clock and reset through Mutable Instruments Yarns.

In both cases, the playback started up pretty tight. But after a few minutes into the song, it started to drift noticeably and it got progressively worse.
My song is set up in such a way that the patterns in the rows are all of equal length, so the rows never shift. When I checked the screen after playback had started to go off-time, I noticed that this row synchronisation was no longer intact.

In situation 2) I noticed another glitch.
After stopping playback using the external clock, when I looked at the screen again, I noticed that the project bpm had changed to 177 (=approximately doubled).
When I pulled out the external clock cables and set NerdSeq back to internal clock, the tempo sounded normal (as if it was still at 88bpm).
However, when I reloaded the project and played it back, it did sound like 177bpm!

After having slaved it from MIDI and setting the NerdSeq back to Internal Master Clock, the bpm (although listed as 88bpm) was also super fast. Going into the menu and manually setting the bpm again fixed it.
Reply
#2
(07-02-2019, 07:23 PM)Acheface Wrote: I have a project that I prepared at 88bpm with NerdSeq's internal master clock. It's a 4:30 minute continuous song and it includes modular tracks, a MIDI track, a Trigger 16 Expander and some sample tracks.
This evening, I tried to run it from my DAW (Reason), also at 88bpm, in two ways:
1) With NerdSeq set to "MIDI Slave" mode
2) With NerdSeq set to "Mod.Slave24" and receiving the 24ppqn clock and reset through Mutable Instruments Yarns.

In both cases, the playback started up pretty tight. But after a few minutes into the song, it started to drift noticeably and it got progressively worse.
My song is set up in such a way that the patterns in the rows are all of equal length, so the rows never shift. When I checked the screen after playback had started to go off-time, I noticed that this row synchronisation was no longer intact.

In situation 2) I noticed another glitch.
After stopping playback using the external clock, when I looked at the screen again, I noticed that the project bpm had changed to 177 (=approximately doubled).
When I pulled out the external clock cables and set NerdSeq back to internal clock, the tempo sounded normal (as if it was still at 88bpm).
However, when I reloaded the project and played it back, it did sound like 177bpm!

After having slaved it from MIDI and setting the NerdSeq back to Internal Master Clock, the bpm (although listed as 88bpm) was also super fast. Going into the menu and manually setting the bpm again fixed it.

As for the drift away, i assume your DAW / computer is the problem. The NerdSEQ works rock solid being slaved with Midi, Sync24 or external Modular clock. Even after hours there is no drift at all. Many users use it like this. It is either your DAW or you might have odd groove settings in some patterns ( you could find out by checking if only one or more tracks but not all are going different)

As for the external clock amount, forget about that for now. The actual timing is measured between each clock. Once you stop a master clock, there is no reliable measuring possible anymore. So value where it ends up can be anything. (I could fix that, but for this i would need to rewrite parts of the clocking. But as it is very good and stable i rather don't touch it at the moment.) In the end it doesn't matter as with a new clock start the calculation starts solid again. So when staying in slave mode, everything is fine. When switching to master, a new clock definition might be needed. Vice versa the same case. Another clock source will always have other clocks.
Reply
#3
(07-02-2019, 07:56 PM)XORadmin Wrote: As for the drift away, i assume your DAW / computer is the problem. The NerdSEQ works rock solid being slaved with Midi, Sync24 or external Modular clock. Even after hours there is no drift at all. Many users use it like this. It is either your DAW or you might have odd groove settings in some patterns ( you could find out by checking if only one or more tracks but not all are going different)
So you're suggesting that the clock from my DAW is not steady? But can't NerdSeq follow that unsteady clock? It also seems to follow a shuffling clock quite well.
I did not deliberately change any groove settings in any of my patterns. Without external clocking, none of the rows runs differently, so how could that problem start when being slaved to a clock?
Reply
#4
(07-03-2019, 06:32 AM)Acheface Wrote:
(07-02-2019, 07:56 PM)XORadmin Wrote: As for the drift away, i assume your DAW / computer is the problem. The NerdSEQ works rock solid being slaved with Midi, Sync24 or external Modular clock. Even after hours there is no drift at all. Many users use it like this. It is either your DAW or you might have odd groove settings in some patterns ( you could find out by checking if only one or more tracks but not all are going different)
So you're suggesting that the clock from my DAW is not steady? But can't NerdSeq follow that unsteady clock? It also seems to follow a shuffling clock quite well.
I did not deliberately change any groove settings in any of my patterns. Without external clocking, none of the rows runs differently, so how could that problem start when being slaved to a clock?

The NerdSEQ is able to also follow unsteady clocks. But thats not what i mean. I think they are other problems here which causes eventually missing or extra clocks. Also i didn't think of that it seem to work well with the internal clock.
Many users are using the NerdSEQ as slave in their setup which works well. So my assumption is something either with your clock source or in your project.

Please just add or send me your project, so i can check it out. Maybe i find something i wasn't aware of, yet.
Reply
#5

.nrd   TRANEN.NRD (Size: 437,47 KB / Downloads: 1)
Okay, Thomas, here's my project attached.
Reply
#6
OK, i can't find any issue here. Slaved with the Digitone as master everything is straight from the begin to the end of the song.
Check your reason settings, midi settings, midi interface settings, priorities etc...
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)