Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
CV16 Expander Firmware V1.1
#1
I just made an update for the CV16 expander with a little fix.

- fixed possible interference in combination with another expander

I added the firmware update instructions and the new firmware file in this post. The expanders can be easily updated through the NerdSEQ.
Please follow the instructions in the update manual.

Cheers!


Attached Files
.nxp   nsa_cv16_1_1.nxp (Size: 33,08 KB / Downloads: 22)
.pdf   nerdseq-expander-firmware-update-manual_1_0.pdf (Size: 31,04 KB / Downloads: 42)
PLEASE use the search function if something have been asked or discussed before.
Every (unnessesary) forum support means less time to develop! But of course, i am here to help!  Smile
Reply
#2
In the instructions, it says:

Disconnect all expanders on the NSA port except for the one to be updated!!!

I assume you wouldn't have included that step if it weren't necessary, but that's certainly a pain, especially if the expanders are spread out across your case. Do you have any planes to change this so that firmware update will only affect the targeted expander so we don't have to disconnect the rest?
Reply
#3
That is one of the reasons the update is needed in some cases.
It works normally like this.
But mainly if you don’t have any issues and all works fine, then you don’t need to update at all.
It doesn’t add any features.
PLEASE use the search function if something have been asked or discussed before.
Every (unnessesary) forum support means less time to develop! But of course, i am here to help!  Smile
Reply
#4
Hi there,

I tried to update by following the instructions exactly but still got an error message.
My CV16 was at address 2. I had the idea to put the jumper on 1 and it worked! If ever...
Reply
#5
(08-06-2020, 08:46 PM)Hey cavimaster Wrote: Hi there,

I tried to update by following the instructions exactly but still got an error message.
My CV16 was at address 2. I had the idea to put the jumper on 1 and it worked! If ever...

So you updated it in the end?
PLEASE use the search function if something have been asked or discussed before.
Every (unnessesary) forum support means less time to develop! But of course, i am here to help!  Smile
Reply
#6
No issues here updating! I followed the instructions leaving only the CV16 connected and appropriate jumper setting. Went smoothly. I originally thought had to update ALL expanders. But nope, just the CV16.
Reply
#7
(08-06-2020, 11:10 PM)XORadmin Wrote:
(08-06-2020, 08:46 PM)Hey cavimaster Wrote: Hi there,

I tried to update by following the instructions exactly but still got an error message.
My CV16 was at address 2. I had the idea to put the jumper on 1 and it worked! If ever...

So you updated it in the end?

Yes!
Simply by changing the jumper of the ID of the CV16 from id2 to id1.
Reply
#8
(08-07-2020, 01:37 PM)Ucavimaster Wrote:
(08-06-2020, 11:10 PM)XORadmin Wrote:
(08-06-2020, 08:46 PM)Hey cavimaster Wrote: Hi there,

I tried to update by following the instructions exactly but still got an error message.
My CV16 was at address 2. I had the idea to put the jumper on 1 and it worked! If ever...

So you updated it in the end?

Yes!
Simply by changing the jumper of the ID of the CV16 from id2 to id1.

Hmm. But flashing for jumper 2 or others works as well. You only also got to set the channel to flash to 2 then. Anyway, it worked so all fine!
PLEASE use the search function if something have been asked or discussed before.
Every (unnessesary) forum support means less time to develop! But of course, i am here to help!  Smile
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)